Internal Site Search Box

1991 shakes and sputters at highway speeds

by Jack
(Alabama)

1991. all stock. 51,000 miles. auto trans. L98. while driving at highway speeds, mostly around 65mph, it will shake and sputter and have little throttle response. no waring and nothing else happens, rpm's don't jump up or down, no warning lights on the dash. when I let off the gas everything smooths out fine. The cars idles fine and runs great at lower speeds. No problems under 55mph. I've owned the car for months and it just recently started doing this. It's driven weekly and I always use 93 octane.
Any ideas what might cause this? Thanks!

Comments for 1991 shakes and sputters at highway speeds

Average Rating starstarstarstarstar

Click here to add your own comments

Feb 21, 2015
Rating
starstarstarstarstar
87 corvette
by: Anonymous

I had the same problem, I purchased high quality plug wires. Problem solved. The old wires I had were less than a year old.

Dec 20, 2012
Rating
starstarstarstarstar
car missing
by: Don

On your intake manifold ,just below your intake ,where your hose connects,their is a small box with a pipe comming out,I think ,and inside it is a diaphragm that goes bad and makes the motor run really bad and uses a lot a gas. I have only seen this once and i'm trying to rememeber
so take a look a i think the cap only has two bolts on it,also if you have a service manual it
might tell you something.Sorry i can't be more specific but i'm old school vettes ,but my buddy has a 89 and that is where i seen that happen.
Let me know if it works.
Don

Click here to add your own comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.

Tips for Tips

Help us make our site Mucho Badassico...! Donate any amount today.  Let us know if you need help putting the awesome back in your Corvette.