Internal Site Search Box

New spark plugs and it's rough start

I recently changed out all plugs on my 77 vette and it seems it's running more rough? Plus, it's hard to start...I have to bury the gas pedal to fire it up? I'm a tinkering guy and not sure where the problem lies?

Comments for New spark plugs and it's rough start

Average Rating starstarstarstarstar

Click here to add your own comments

Nov 10, 2012
Rating
starstarstarstarstar
rough start
by: Anonymous

did you ues a spark plug socket or just a 5-8 deepwill socket sounds like you broke the porclinc on the some of the plugs did you also gap the plugs before installing if you rev the engine will it back fire if so plug wire crossed was it rough starting before you changed the plugs if not then this where the trouble is when was the last time spark plug wires were changed i would peplace the plugs again

Nov 10, 2012
Rating
starstarstarstarstar
rough start
by: Anonymous

did you ues a spark plug socket or just a 5-8 deepwill socket sounds like you broke the porclinc on the some of the plugs did you also gap the plugs before installing if you rev the engine will it back fire if so plug wire crossed was it rough starting before you changed the plugs if not then this where the trouble is when was the last time spark plug wires were changed i would peplace the plugs again

Click here to add your own comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C3 Corvette Ask!.

Tips for Tips

Help us make our site Mucho Badassico...! Donate any amount today.  Let us know if you need help putting the awesome back in your Corvette.