1970 Ignition Switch T/T

by Pete Z
(Houston, Texas)

1970 Corvette 454 4-speed
Tilt Telescopic A/C
I just completed changing wires under my hood and now under my dash with NEW Wiring harness. Prior to changing out the Dash portion my headlights and wiper door and wiper motor worked (with the new wiring harnesses under hood). Once I installed the new under dash harness - only my headlamps work.
The wiper motor is not working, neither is the vacuum door.
I checked for voltage to the cutoff switch under the dash in between the two vacuum over-rides. It is not receiving voltage. Fuse is good, reconfirmed with meter.
Car is also difficult to start, did not appear to be a problem before
Any suggestions
Do you have a photo of correct placement of connectors into the Ignition Switch
How do you adjust Ignition Switch

Thanks
Pete

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C3 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these