A/C & Heater Blower Motor-'75 Corvette

by Bill
(Pittgsburgh, PA)

This is strictly an A/C issue. I have no fan speed from the blower motor. I was advised to check the function of the blower motor by removing the purple wire and feeding the motor directly from the battery to see if the blower works on high speed. The purple wire appears to be a push on/pull off connection but I can't get the thing off. Is there a trick to disconnecting the purple wire from the blower motor?

Any help is appreciated.

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C3 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these