bleed rad in a 69 corvette

Hi there i have a 69 corvette and replaced the temp sender unit yesterday as i removed the sender water came out of the block.
i refilled the rad and now when i start the car from cold the temp gauge rises to the red and then back down just above 100, i have a new thermostat and just replaced the rad cap to original as well.

i had to pull over tho the side of the road to let the gauge come back down.
so i think it may have an air lock in the system
how do i remove it from the system??

lou

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C3 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these