Blower runs, but nothing comes out of the vents.

by Anthony
(Davison, MI.)

Hello, I recently purchased a 1980 L48 with 40k original miles. When I turn on the A/C, heat or fan - I can hear the blower engage but I get nothing from any of the vents (windshield, dash or floor) even though I hear the blower running strong. Fuse is fine.

This is my first Corvette, and I've always loved the look of the C3's. I have the shop manual, but I do not see troubleshooting for this issue. Any ideas, diagrams and pictures would be very much appreciated.

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C3 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these