1994 c4 LT1 idle problem

by Lee
(Warwick, R.I. USA)

I have a 1994 c4 w.lt-1, milagge 107,000 once the car gets up to operating temp the idle starts to jump around when in gear or in neutral. It has an automatic trans. The idle has gone as high as 1100 to 1200 rpm. There are no dtc codes stored and no check engine light. Please help, what can cause this?

Comments for 1994 c4 LT1 idle problem

Average Rating starstarstarstarstar

Click here to add your own comments

May 31, 2011
Rating
starstarstarstarstar
idol problem 1994 corvette
by: Sam

Ihave the same problem. Did you find a solution? Thanks, Sam

Click here to add your own comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these