1994 Coupe Lumbar System

by Marlin
(Fort Pierre, SD)


Having an issue with 94 Coupe Lumbar System. When activating the switches, the bladders were not inflating...When I pulled the passengers seat....I noted that a hose on the lower part of the manifold was not connected...I reconnected that hose and all the bladders inflate,...when I "deflated" the bladders that same hose popped off the fitting...my question....Obviously that is not normal....is the fitting worn out or do I have more problems that that?

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these