'93 c4 won't start after alternator change

by chip
(lakeland, florida)

I changed out an alternator for a 1993 corvette (mine) and found one wire that goes on the alternator bundle (3 wires) was disconnected. I spliced the wirewith insulated butt splices. Connected the battery and the engine would'nt start. It sounded like in the old days ,with distributors, that the engine suddenly had got out of time. How can this be I just changed alternators. The car had been sitting for about 2 years,but ran fine for the past week, now his. Can you help?

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these