99' Bose rear speakers low volume, but clear not blown.

by Jeff Longhurst
(Mankato, Minnesota)

Hi, my 99' hatch rear Bose speakers play well but low volume, is this a fuse thing, wire connection, I heard of the problem before. Also I have the memory seats, and the seat moves all the way back when I turn the car off, I think a previous owner had the seat in a weird position, it tried to move back and bottomed, motor vs. Seat, now the seat wiggles about .5" on accell, decell. I'd rather ask then tear my car apart, it's almost perfect. Jeff (507)720-1910, jefflonghurst1 at hotmail.com or on Facebook.

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C5 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these