Ac/ Heater fan not working

by Bill
(Great Lakes)

My 86 corvette AC/heater fan will not work. I relaced a blown fuse in the fuse box and the low/med fan settings came on. Switched to Hi the fan would not work and when I returned to low/med speeds they will not work. Ive checked the fuse and it's okay. I'm told there is a direct line from the battery for the high speed fan function on the fan motor that has a fuse or fuse link in it. I can't find it. Any help as to where the fuse is and what color the wire is? I've also replaced the blower motor resistor but still no fan. When putting a test light on the two connection wires (both black)that attach to the fan motor I get nothing.
Can anyone help this novice electrician.

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these