Battery low and will not start the car after 1 week

by Dan
(Warminster, Pa. 18974)

I have a 2003 ZO6 I just put my 2nd battery in and I still have to jump it with my jump box after 1 week. Lights are bright, I do not lose radio channels, but my HUD is not ware I left it and my clock is not the right time. What is going on?

Answer:
May want to look at alternator and charging circuit. Was is the charging voltage during driving? It should be above 14V.

For storage over longer periods we recommend:
CTEK Multi US 3300 12-Volt Smart Battery Charger

This is the same charger GM licensed as a factory option on the C6 Corvette so you know its good!


Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C5 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these