changed small hose on plenum and water leaking out from back of motor

by Gil
(palmdale ca)

I did a pressure test on radiator and found small u shaped hose had leak,replaced with a hose that was crimped (kinked) did another test and held pressure, then did a radiator flush and now i have water pouring out from somewhere under car could the hose i replaced have blown something out because of flow restriction. the car is 85 vett vin 8 with over one hundred thousand miles car ran beautifully until i did this could the flush and the crimped hose have blown a freeze plug? or is there some hose on the motor im not seeing that blew.Water just pours out from somewhere under middle or rear of motor when filling radiator. Did I kill my car?

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these