Check engine light on

by Barry Hines
(Vincennes, Indiana)

Noticed fluid under car, found no bad hoses, saw a little weepage around water pump. Replaced it today with new AC Delco pump. Replaced antifreeze, started up, and service engine soon light came on, car had not even ran long enough to indicate any issues. this is a 95 Corvette LT1. Have not bled the air out of system yet as it was getting dark outside. Temp guage went up to 225, while readout in center of dash never got off 145. this is one owner car with 80,000 miles on it, never had any issues first time any bolt has ever been turned on engine. Any Ideas

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these