corvette has a miss

by Rickey
(lawrenceburg tn)

I have a 1987 tune port got a miss. Here is what I have Replaced new injectors- new plugs -plug wires- dis cap rotor button- pick up in dist- new module- new oxygen sensor. when I set the time it Idles ok but when I give it gas it misses like low in timing can hold gas where it misses and advance the dist while running and it will rev up could this be the computer causing the problem. if you can help email me at ricnjane@yahoo.com if you know please help but don't wont no bull shit. thanks for your help

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to C4 Corvette Ask!.
























Chris Trautman @ Corvette Assembly Plant 2019

About Us: Corvette Web Central | Owner Bio: Chris Trautman

Established in 2008 by Chris Trautman, Corvette Web Central quickly grew into one of the top leading Corvette enthusiast websites globally. 

"This website is a passion of mine just as much as being a Corvette owner," says Chris.  He was frustrated trying to find information on the internet about Corvettes which was was not biased or influenced somehow. 

He has owned three Corvettes over the last twenty years and does not plan to stop owning one anytime soon.

Note: Some links on this page are part of our affiliate program and provide a small portion of proceeds to fund the administrative costs and to fund more product reviews.  We are not paid to perform the reviews or are we given any products for free.  

You might like these